Get exchange rate error

We have 2 servers a test server and a production server. On the test server, the endpoint returns the positive results as expected

curl --request GET ‘
–header ‘Authorization: My bearer token’

{“status”:“success”,“message”:“Transfer amount fetched”,“data”:{“rate”:132.071898,“source”:{“currency”:“KES”,“amount”:132071.8978},“destination”:{“currency”:“USD”,“amount”:1000}}}

However, on the production server am getting an error 403 when running the same same curl request this is the error am getting :

403 Forbidden

403 Forbidden

Any idea as to why am getting this on prod server whilst the other endpoints are working correctly.

Hi @Stanley_Mbote :wave:

Thanks for sharing this experience with us,

We introduced a feature recently where API calls from IPs not whitelisted are rejected. This can be fixed by whitelisting IPs. Here are some steps to so this from your dashboard;

  1. Log into your dashboard.
  2. Select Whitelisted IP address from your settings menu.
  3. Click on the “Add IP address” button.
  4. Enter your server IP and confirm Configuration with 2FA.
    You should add in the interim while you whitelist static IPs (You can check out this content for more context.)

After setting up the above, you can then retry the API request.