403 Forbidden both in test and live

I get 403 forbidden error when trying to do a transfer on both test mode and live both localhost and live server here is a snippet of my code
$ch = curl_init();
curl_setopt($ch, CURLOPT_URL, ‘https://api.flutterwave.com/v3/transfers’);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1); curl_setopt($ch, CURLOPT_CUSTOMREQUEST, ‘POST’);
curl_setopt( $ch, CURLOPT_POSTFIELDS, [
“account_bank” => ‘MPS’,
//“account_number” => $withtype === “1” ? $partner->phone_1 : $partner->account_number,
“account_number” => “256781234567”,
“amount” => $requested,
“narration” => $partner->name." “.” Wallet withdrawal.",
“currency” => “UGX”,
“reference” => $reference,
“beneficiary_name” => $partner->name,
‘redirect_url’ => route(‘callback.payout’),
] );
$headers = array(); $headers = 'Authorization: Bearer ’ . $key;
$headers = ‘Content-Type: application/json’;
curl_setopt($ch, CURLOPT_HTTPHEADER, $headers);
$response = curl_exec($ch);

$response = curl_exec($ch);
$error = curl_error($ch);

Hi @Kaka_Isaac

Thank you for sharing this experience with us,

We introduced a feature recently where API calls from IPs not whitelisted are rejected. This can be fixed by whitelisting IPs. Here are some steps to so this from your dashboard;

  1. Log into your dashboard.
  2. Select Whitelisted IP address from your settings menu.
  3. Click on the “Add IP address” button.
  4. Enter your server IP and confirm Configuration with 2FA.
    You should add in the interim while you whitelist static IPs (You can check out this content for more context.)

After setting up the above, you can then retry the API request.


Hi i whitelisted both and the ip for twende.io my Merchant ID: 100097011 but still i get the same response

Sorry for the late response

Hi @Kaka_Isaac

I apologise for the inconvenience this might be causing you,

Kindly share the name of the platform your application is currently being hosted.

App is https://twende.io and the server is a linux server running nginx
Thanks in advance

Hi @Kaka_Isaac

Thank you for sharing this information with us,

Kindly send a mail to developers@flutterwavego.com with the following;

  • Business name,
  • Merchant ID,
  • Unique IP to be whitelisted (static), and
  • The error message gotten.

Best regards